Please Note: If you previously had an account, you will need to create a new account.

Preachit 5.0

Preachit 5.0

Version: 5.0.0 beta

The No 1 Sermon Library Component for Joomla. This file contains the component, modules and plugins in one easy to install packet. Please note that this release require Joomla 4 to run.